OMG! ZIRIA! ZIRIA!! ZIRIA!!! IT ACTUALLY HAPPENED!! 34 YEARS LATER!! The epic/legendary Tengai Makyou/Far East of Eden: Ziria JRPG has finally been localized! Supper the Subtitler struck again! Simply unstoppable, NOTHING can prevent him from TOTAL PCECD localization domination!!!! WHACHA GONNA DO BROTHER?!?!
Main Menu

Recent posts

#1
Hi there!
I've never seen a motor failing in any console, but definitely it's a thing that exists, hence, can fail xD
If you applied some voltage to it and it didn't move (and you applied some to the other motor and it did moved just to check your power bench), it's either that you put a low voltage (I don't know the specs of it), or it's definitely dead and it's time to replace it.
#2
Hello everyone, hope someone can help me.

Few days ago I got a PC Engine DUO-R very dirty and was sold as not working.

After getting the correct power supply (and the correct tip) I powered on and it worked, I saw the Super CD System 3.0 screen, so I first tested the HuCard part and it worked fine, it booted every Hucard Game I throw at it, but the control pad wasnt working it was very erratic sometimes one button worked sometimes doesnt, so the problem was that the controller port had a cold solder, so I reflow and applied fresh solder and now the controller worked flawlesly.

Then I checked the CD part and at first it began to spin the disk (I just heard it because no window) and it sounded that it was spinning like crazy... and after some time the system just said "set Disc" no CD game worked.

So I took everything apart and tested again and in fact the disc was spinning like crazy very fast but the laser lens never moved at all..even when I released the door switch it keeps spinning but got the "set disc" text.

I tested again without disc just moved the laser to the outer side to see if it moves to the start position and no it never moved, just the motor that spin the disc was spinning like crazy but the motor of the laser doesnt moved at all. I tested the lines that give power to the motor and everything seems fine it receives power on those lines. I took apart that motor and applied some voltage and didnt moved..

Does someone know what could be wrong? Its possible that the laser motor its broken? or should I have to check something else.

Thanks.
#3
Could be a bad 6270 or 6280 which would require a system to be used for parts. The only bummer is lots of times if a system is being sold for parts, one of those two chips is dead. So it's a crap shoot finding exactly what you need from a broken/parts console.

Try and find a broken PCE or turbografx console that boots with glitchy/blocky looking graphics as this is usually caused by bad ram and not one of the HU chips.
#4
Hi :)

I changed IC520 composant .. same problem
I removed HU6280, cleaned and reflowed it...  same problem  :cry: 

Next, i will try to reflow HU6270 but i'm not really hopeful

Seems this console will join the graveyard  :ysdance:
#5
Thanks a lot for your help !

I'll do everything you asked me to test and get back to you :)

 :yuki:
#6
Off-Topic / Re: Game Sack
Last post by NightWolve - 05/27/2024, 03:07 AM
GameSack-16: Joe's Top 10 TurboGrafx-16 Games!

#X Bonk's Revenge
#9 R-Type
#8 Devil's Crush
#7 Soldier Blade
#6 Bloody Wolf
#5 Splatterhouse
#4 Lords of Thunder
#3 The Legendary Axe
#2 Ys Book I & II
#1 Dracula X: Rondo of Blood
#7
Sorry, I'm sure there are certain voltages that would give it away if the 6280 is no good but unfortunately I don't know what they are.

Anytime I've had a system with a solid white screen and all the other things check okay that I mentioned, then 98% chance it's a dead HU6280. So I just change it out.

What stinks is finding a replacement as these chips can only be found in other consoles.
Double check the traces under the board for the Hucard slot pins. If all traces test good to the 6280 chip, then the chip is probably bad.

Have you tried reflowing solder for the 6280 or 6270? Sometimes bad traces exist in between both of those chips causing the same issue.

Heating up/reflowing solder on the pins doesn't always permanently fix a bad trace but when heated up, a trace might start working again temporarily.

I will sometimes heat up each pin(for the HU chips) one at a time and then power on the console to see if anything changes. If does and the system starts working, you know which trace to run a wire to repair.

More info here
https://www.pcengine-fx.com/forums/index.php?topic=21837.0

#8
Hi Keith Courage,

Thanks for your reply and for your time.
I checked both regulator voltage and i obtained about 10V IN et about 5V OUT. Seems its Ok.
I checked many time the Mainboard and i dont see any burning traces or corrosion.
i checked under the hucard port for see all points and all pins, no corrosion or other.

i m so frustred  #-o I want to understand what the problem is... even if I can't fix it.

> Im ready to test HU6280. PLease can you tell how to test ? i have another Working PC engine duo. Maybe i can take values from working console and compare with not working console ? Need osciloscope or only multimeter ?

Thanks a lot

#9
Unfortunately the problem you are describing(white screen) isn't usually caused by bad capacitors.

This can be caused by many different things. A bad 7805 voltage regulator, Bad traces or connections on the board(usually caused by corrosion under the hucard slot), a bad HU6280 CPU, or in some rare cases a shorted capacitor but this isn't usually the case.

Start looking for corroded traces or via hole connections under the card slot. Also check that all the traces for the card slot pins are good.

#10
Hi,

I guess i checked Reset Pin. But i checked only continuity signal.

IC901 (C6280) pin 11 > HUcard port pin 36 continuity OK
IC903 (C6270) pin 24 > Hucard port pin 36 continuity OK

Is this the right way to test RST pin ? or i must to test something else (about RST)?

Thanks a lot  :D